Page 1 of 1

Symphony GUI pulling focus in Windows

Posted: 11 Apr 2021 19:10
by CrushLoop
I'm currently in the learning phase with Symphony. My intention is to replace my Lemur based workflow using an application that runs directly under the same OS as my DAW (Cubase 11). One thing that is causing some headaches for me is that Symphony pulls focus (Windows 10, ver.20H2) when touched. This means that within Cubase, I can no longer see the VST GUI of whatever element I'm trying to use Symphony for the moment I touch a mapped control within Symphony. This does pose some challenges, especially in the initial setup of a controller. Is there a method to prevent Symphony from pulling focus from Cubase when a control is touched within a Symphony GUI? I ask because I have also recently started using DTouch V2 and it does not have the same issue (touching any control or grabbing and moving any element within DTouch does not pull focus from Cubase).

Re: Symphony GUI pulling focus in Windows

Posted: 25 Apr 2021 19:14
by CrushLoop
Just following up with some things I've tried since I had some time this weekend.

The applications PinWin (vzakharov) and AlwaysOnTop (jparnell8839), both .NET projects, did not work to solve the issue of focus pulling in Windows 10 from Cubase 11 for me. I am going to look at some more involved applications to try and work around this issue, but the aforementioned, simple solution applications did not work for me. Touching a control within Symphony still makes any visible VST GUI windows disappear within Cubase 11 since the focus is stolen by the Symphony application. (To be fair, clicking on any other application in Windows 10, other than DTouch, has the same result.)

Re: Symphony GUI pulling focus in Windows

Posted: 25 Apr 2021 20:32
by CrushLoop
<SOLVED w/caveats>

The issue appears to be primarily a Cubase one. What's happening is the global Cubase command for "Always on Top" located under -- Edit > Preferences VST > Plug-Ins -- will not affect VST GUIs in an expected way if your project view window size is above a certain percentage of your monitor's size at the moment you add a VST to a track. If your session in Cubase is at or near full-screen when you add a VST element, the "Always on Top" feature within your VST instance will ignore the global setting and will be enabled. This is intensely irritating, but is 100% reproducible for troubleshooting purposes.

The easiest way to see this issue is, if you have your arranger window in full-screen mode or if it's taking up more than 70-ish% of the viewable space on your monitor panel, then newly added VSTs will always have the "Always on Top" feature enabled regardless of the Cubase global setting. When this option is active on a VST within Cubase the VST GUI will disappear the moment you click on another non-Cubase window, or in my case when I grab a control within Symphony.

The workaround, not a true fix, is to be sure to double-check each VST after loading within Cubase and disable the "Always on Top" feature within that instance of the VST if it's enabled. I have linked an associated thread on the Steinberg forums that helped suss out the actual issue. Comments from user fgimian led me to correctly diagnosing the issue. ... /643966/10.

Why there's a global setting within Cubase to turn off this function that doesn't actually work globally in all situations...I haven't the slightest idea. That said, at least I can continue moving forward with Symphony as it still is superior in practice and is way more user friendly than Lemur. This also isn't directly a Symphony problem at the end of the day.

That said, I'd love to see the same or a similar methodology for Symphony as used in DTouch that bypasses this issue all together.